Webapp functionality degraded

Incident Report for CloudAfrica

Monitoring

All cluster services are running and stable.
All functionality on our FrontEnd at https://app.cloudafrica.net has been restored and VMs can be manipulated using the buttons and tools available.
We will continue to monitor the cluster services.
Posted May 12, 2026 - 23:43 SAST

Identified

Functionality on https://app.cloudafrica.net is still unavailable and any operations on VMs are unavailable.
We are working on resolving the cluster state and hope to have it back up and all functionality restored in the next hour.
All customer VMs are stable, running and available over the internet using tools like ssh/rdp/telnet etc.
Posted May 12, 2026 - 22:23 SAST

Investigating

We're currently experiencing limited functionality on our frontend at https://app.cloudafrica.net
All customer VMs are available via the internet, but functionality other than reading information is unavailable at the moment.
VMs cannot be stopped, started or restarted and all functionality regarding firewall rules and backups are offline for the time being.

We expect functionality to return within 1-2 hours.
Posted May 12, 2026 - 21:50 SAST
This incident affects: Web Sites.